Forum Spammed

Forum feedback, suggestions, report glitches.
Post Reply
User avatar
kyle.bowker
Site Admin
Posts: 760
Joined: Thu Sep 27, 2007 3:35 pm
Car: 1991 Mazda Miata
CDC Member#: 91
Location: Alexandria, VA
Contact:

Forum Spammed

Post by kyle.bowker » Wed May 06, 2009 1:19 pm

The forum has been getting attacked by spammers despite the software being up to date. I had to delete thousands of inactive users and dozens of accounts that were activated by spammers. I apologize to any legitimate users who were accidentally pruned as a result of this housekeeping. I plan to customize the registration form to make it more difficult for these malicious bots to attack our site. They have already broken the CAPTCHA so I will add a special question to the registration form that must be answered correctly before the new account registration can be submitted. Don't worry, if you are a legitimate user you will have no trouble answering this question.

User avatar
kyle.bowker
Site Admin
Posts: 760
Joined: Thu Sep 27, 2007 3:35 pm
Car: 1991 Mazda Miata
CDC Member#: 91
Location: Alexandria, VA
Contact:

Re: Forum Spammed

Post by kyle.bowker » Tue Jun 02, 2009 7:34 pm

I finally got around to adding a new anti-spam question to the forum registration form. In order to prevent spambots and other illegitimate users it asks forum registrants to answer a simple question: "What year was the Capital Driving Club founded?" Hint: the answer is in the FAQ section of the Capital Driving Club website. I also went ahead and deleted about 500 inactive spambots and about a dozen active spambots from the forum. I hope I got them all and I apologize if any legitimate users got caught up in this dragnet. Please e-mail either Ed Chan or myself if you are having trouble.

Post Reply